Have an old iPhone? You should really download this security update.

Have an old iPhone? You should really download this security update.

Non-early adopters take note: Your iPhone needs a tune-up. Like, now. 
That’s according to Apple, which on Monday released a security update specifically targeted to older devices. According to the company, iOS 12.5.4 is available for those environmentally conscious consumers still holding onto their iPhone 5s, iPhone 6, iPhone 6 Plus, iPad Air, iPad mini 2, iPad mini 3, or 6th generation iPod touch.
The update fixes three vulnerabilities that allowed for potential arbitrary code execution (that’s not good), two of which Apple says “may have been actively exploited.” In other words, criminals or oppressive governments may have been exploiting these vulnerabilities on real people’s phones. Read more…More about Apple, Iphone, Cybersecurity, Tech, and Cybersecurity

Original Article